https://pantsbuild.org/ logo
#general
Title
# general
s

sparse-lifeguard-95737

06/02/2022, 10:08 PM
my team has a split between macos and linux for local dev boxes. we’re also using the pex-based lockfiles from 2.11. we’ve noticed recently that PRs which modify the locks will update the value of
platform_tag
in each lockfile from:
Copy code
"platform_tag": [
  "cp38",
  "cp38",
  "macosx_12_0_x86_64"
]
to:
Copy code
"platform_tag": [
  "cp38",
  "cp38",
  "manylinux_2_31_x86_64"
]
and vice-versa, depending on the OS of the developer making the change we haven’t noticed any negative results from this other than confusion during code review, and I see artifacts for all platforms listed in the lockfile regardless. what’s the purpose of
platform_tag
? do we need to worry about it flapping back and forth between values?
oh, I guess based on https://github.com/pantsbuild/pex/issues/1685 the answer is that it’s not used 🙂
h

hundreds-father-404

06/02/2022, 10:11 PM
Indeed. I'm not 100% certain how it will impact backwards compatibility, e.g. if we need to bump the version of the lock format
r

rhythmic-morning-87313

06/23/2022, 7:04 AM
I've also hit this problem. Alternating seems to be safe but adds an extra concern for code reviews.
s

sparse-lifeguard-95737

06/23/2022, 2:11 PM
@rhythmic-morning-87313 looks like the tag was removed in pex v2.1.93. I haven’t tried it yet but I think you can manually upgrade using the
[pex-cli].version
config in Pants
👍 2
r

rhythmic-morning-87313

06/27/2022, 9:12 AM
Copy code
UnsupportedVersion: The option [pex-cli].version is set to pex>=2.1.93,<3.0, which is not compatible with what this release of Pants expects: pex<3.0,>=2.1.90. Please update the version to a supported value, or consider using a different Pants release if you cannot change the version. Alternatively, update [pex-cli].use_unsupported_version to be 'warning'.
i'm using 2.12.0rc2
it seems that
>=2.1.93,<3.0
fits within
>=2.1.90,<3.0
but it says not...
ahha..
followed this thread and now it seems to work
h

hundreds-father-404

06/27/2022, 3:49 PM
Hm, that's a confusing error message. Do you know what this was?
s

sparse-lifeguard-95737

06/27/2022, 3:53 PM
(my guess) Joongi tried to set
version = "pex>=2.1.93,<3.0"
, and Pants tried to use that whole string as the literal version (instead of recognizing it as a version range)
💯 2
h

hundreds-father-404

06/27/2022, 3:56 PM
Ahhhh, that would do it. Thanks!
r

rhythmic-morning-87313

06/28/2022, 2:49 AM
yeah, i thought the
pex-cli
section would use the same
version
field format like other Python tool sections...
👍 1
2 Views