https://pantsbuild.org/ logo
#general
Title
# general
h

hundreds-father-404

07/07/2022, 8:12 PM
Another poll for a new policy: Pants will release for the most recent Python version + 2 before. So, Pants 2.14 will be 3.8-3.10. When Python 3.11 is released, the corresponding Pants release series will be 3.9-3.11 (Pants release series will support their interpreter range indefinitely. Meaning, Pants 2.13 will always be 3.7-3.9, for example)
👍 14
👎 1
Why limit to 3 Python versions per release series? Every version we support makes our CI slower & us a worse offender on PyPI for storage size. We already are in the top 20 worst offenders on PyPI
h

happy-kitchen-89482

07/07/2022, 8:20 PM
Also note the very important distinction that what Eric is referring to is the Python version required to run Pants itself. Your own code can use whatever interpreter version.
1
And that in the future we hope to bundle Pants with a baked-in interpreter as a completely standalone binary, and all this will be moot.
2
🔥 1
🚢 1
🚀 1
🎉 1
👖 1
1
c

careful-address-89803

07/07/2022, 8:38 PM
Ubuntu 20.04 comes with python 3.8 by default and is only eol in 2025. We don't have to match support with them, but we should be aware that we'd be dropping support for the default conf for that os version. We could probably just add a link to getting the other versions of python through Deadsnakes PPA.
1
e

enough-analyst-54434

07/07/2022, 8:47 PM
Keep in mind as pointed out elsewhere it will not be / may not be moot for plugin authors; they'll rely on plugin code working with the Python we bake in.
👍 1
2 Views