Newbie question: when running `pants_from_source` ...
# general
Newbie question: when running
to test changes, is interpreter constraint
somehow added? I've been building with
and its been working fine on 2.13 rc, but running from source is failing because of conflicting constraints
Pants must itself run on >=3.7,<3.10 so that's coming in conflict there.
so I have both 3.9 and 3.10 on PATH, and when running pants prod version, it worked out ok
The difference here is you're using Pants from sources. We don't have that setup to handle multiple resolves, which I think is what you'd need here.
Someone else may be able to provide guidance from experience working around this. I'm not sure how you'd do it off the top of my head.
I see. Thanks. Not a blocker for now, I can adjust to 3.9 and test my changes
If you can do that, definitely best for now.
wait is this for a pants plugin? generally the version of Python used to run Pants != the version used for your own code, except for Pants plugins
A plugin may or may not be involved. This is using pants from sources.
Does that just work with conflicting ICs in the top level pants.toml?
It should. It simply runs our
bash script from
, which can be a different Python version than