Just wanted to confirm if pants supports django v4...
# general
Just wanted to confirm if pants supports django v4 or not. Cuz I an getting error while generate lockfiles with this version.
Copy code
ERROR: Could not find a version that satisfies the requirement Django<5.0.0,>=4.1
ERROR: No matching distribution found for Django<5.0.0,>=4.1
Pants doesn’t need to support django, that’s an error telling you that, most likely, your listed interpreter constraints aren’t compatible with those versions of django.
@ancient-france-42909 is right - Pants should be able to install any published artifact that pip can install on the given interpreter version.
Generally, I find it very hard to understand why pants picks a certain interpreter version, back when we had a mixed 3.6/3.7 it was painful, and even seamingly harmless things could (and still can) break things, but that’s not really pants’ fault (except the fact it’s hard to track down why it makes certain decisions)
👍 1
Gotcha, it worked now. Thanks. This issue gave a one level deeper understanding of what pants is about.