https://pantsbuild.org/ logo
#general
Title
# general
h

handsome-sunset-98068

08/24/2022, 5:01 AM
Just wanted to confirm if pants supports django v4 or not. Cuz I an getting error while generate lockfiles with this version.
Copy code
stderr:
ERROR: Could not find a version that satisfies the requirement Django<5.0.0,>=4.1
ERROR: No matching distribution found for Django<5.0.0,>=4.1
a

ancient-france-42909

08/24/2022, 6:16 AM
Pants doesn’t need to support django, that’s an error telling you that, most likely, your listed interpreter constraints aren’t compatible with those versions of django.
h

happy-kitchen-89482

08/24/2022, 6:24 AM
@ancient-france-42909 is right - Pants should be able to install any published artifact that pip can install on the given interpreter version.
1
a

ancient-france-42909

08/24/2022, 6:28 AM
Generally, I find it very hard to understand why pants picks a certain interpreter version, back when we had a mixed 3.6/3.7 it was painful, and even seamingly harmless things could (and still can) break things, but that’s not really pants’ fault (except the fact it’s hard to track down why it makes certain decisions)
👍 1
h

handsome-sunset-98068

08/24/2022, 6:58 AM
Gotcha, it worked now. Thanks. This issue gave a one level deeper understanding of what pants is about.
4 Views