https://pantsbuild.org/ logo
#general
Title
# general
b

brainy-solstice-27042

09/19/2022, 9:14 PM
I have a python binary that uses GDAL to do some image processing. In the past, we've lived with using GDAL 2.4.0 but we are now trying to use GDAL 3.3.2. The GDAL package needs to be installed from source as the docker images we use only support up to 2.4 unless you install yourself. If I do a ./pants repl on the binary target, I can import gdal just fine and it reports version 3.3.2, however if I try and run the PEX, python says it can't find GDAL 2.4.0. Is there anything special I need to do to tell pants that I installed GDAL manually? My BUILD file references 3.3.2 which should match what's installed in the container
r

refined-addition-53644

09/22/2022, 9:00 AM
This doesn't answer your question exactly but you can install from source using PEX too. https://www.pantsbuild.org/docs/python-third-party-dependencies#lockfiles
3 Views