https://pantsbuild.org/ logo
#general
Title
# general
a

ambitious-actor-36781

09/20/2022, 3:53 AM
has anybody had any issues with grpcio as of late? Been chasing build issues due to an unrelated change. But under the aws/codebuild/amazonlinux2-standard:3 image
./pants package something/that/uses:grpcio
works. but under our "other" image we're being forced to use, something gets upset and tries to compile grpcio, and subsequently fails. Yet when I run
pip3 install grpcio
it seems to download a compiled version.
1
e

enough-analyst-54434

09/20/2022, 4:06 AM
It looks like the last few stable releases of grpcio ship glibc 2.17 / manylinux_2014 wheels for ~all pythons. Does you problem image have an older glibc?
Asked differently, what does pip3 mean? What interpreter is is associated with? Python 3.8, 3.9 or ...? Is it associated with the Python you actually want / use? Of course if your image has only 1 Python installed, the answer is yes, but otherwise...
a

ambitious-actor-36781

09/20/2022, 4:08 AM
well now i can't replicate it. But installing it manually with pip3.10, 3.9, 3.8 and 3.7 all installed fine.
ohh ding. solved it. Had some old version locked in lockfiles.
🎉 1
2 Views