https://pantsbuild.org/ logo
#general
Title
# general
a

ambitious-xylophone-5772

11/02/2022, 5:48 PM
Hi all! Our CI seems to have recently broken during the
./pants tailor --check
run. We haven’t seem this happen before but we seem to be hitting:
Copy code
No valid Python interpreter found. For `pants_version = "2.13.0"`, Pants requires Python 3.7, 3.8, or 3.9 to run. Please check that a valid interpreter is installed and on your $PATH.
Please note that we are using the Github CI Action Runners
It seems that the python versions should exist
e

enough-analyst-54434

11/02/2022, 5:56 PM
Installed software is Python 3.10.6, cache tools includes more. I think you need to add those to the PATH. We use those in our own CI, but use the github setup-python action for that: https://github.com/pantsbuild/pants/blob/8fd8960ccb014f0e0bade811db970d513aedcef2/.github/workflows/test.yaml#L26-L29
👀 1
Do you use
actions/setup-python
or similar?
a

ambitious-xylophone-5772

11/02/2022, 5:57 PM
No we don’t actually - I have no idea how we’ve been getting away with this for so long 😄
e

enough-analyst-54434

11/02/2022, 5:57 PM
Aha, ok then.
Did you just upgrade to Ubuntu 22.04 or were you using latest? 20.04 defaulted to an installed Python version that worked with Pants. 22.04 is Python 3.10 so does not.
👀 1
a

ambitious-xylophone-5772

11/02/2022, 5:58 PM
Using latest
e

enough-analyst-54434

11/02/2022, 5:59 PM
That will torch you every time.
Pin those deps!
👍 3
📌 3
a

ambitious-xylophone-5772

11/02/2022, 6:00 PM
Yup you are spot on. It seems like just yesterday the latest was using 20.04
Thanks again @enough-analyst-54434
e

enough-analyst-54434

11/02/2022, 7:08 PM
You're welcome.
27 Views