https://pantsbuild.org/ logo
#general
Title
# general
d

dry-match-62274

11/24/2022, 6:33 AM
Hi guys I have a question, we stayed in pants 1.30.4 and recently some of our member changed to a M1 processor Mac and is having some issue during setup, is there any way to let pants1 running with M1 processor or upgrade to pants 2 is the only solution? https://www.pantsbuild.org/v1.30/docs/troubleshooting#running-pants-with-m1-macs--apple-silicon I have found this doc, we will try this first.
b

busy-vase-39202

11/24/2022, 12:30 PM
Many of the team members are in the U.S., where today is Thanksgiving holiday. So support may be slower than usual, until Monday. Meantime, I wonder: have you looked into whether Pants 2 is realistic option for you? I realize upgrading is a significant inconvenience, but 1.30.4 is nearly 3 years old and Pants 2.x is over 2 years old. Pants 2.0 was a from-the-ground-up rewrite because the team was so dissatisfied with v1.x's fundamental design. There's a tremendous amount of leaps forward in 2.x, especially wrt to perf and UX, that you're missing out on. M1s didn't even exist way back when 1.30.4 was released.
d

dry-match-62274

11/25/2022, 2:16 AM
@busy-vase-39202 Hi, thanks for the information, we tried some early version of pants2 when it just comes out, If I remember correctly the early versions did not support Scala/Java so we stayed with Pants1. We have some validating tickets for Pants2 / Bazel from late 2021, but not much work has being done at the moment.
b

busy-vase-39202

11/25/2022, 10:52 AM
JVM support was released a year ago, so hopefully can meets your needs by now. It was a high priority for the team to add that. @witty-crayon-22786 or @ancient-vegetable-10556 would be the best people to tell you more about JVM support in Pants 2. iirc, @witty-family-13337 uses the JVM support at his company and may also be able to give insight into how it's worked out there.
👍 1
4 Views