is there a way to turn off pants filesystem change...
# general
f
is there a way to turn off pants filesystem change detection? i’m not exactly sure why, but for some reason it’s detecting changes in a loop for the command im trying to run in a
Process
… πŸͺš
βœ… 1
ah, looking through global options i found
--[no-]watch-filesystem
β€” sounds promising!
ugh, even with
Copy code
./pants run apps/demo:run-nix-flake --no-watch-filesystem --no-pantsd
i see
Copy code
11:45:08.68 [INFO] Filesystem changed during run: retrying `Run` in 500ms...
in a loop ….
okay, i ended up in rust territory now … πŸ˜†
g
This happens if you're passing invalid data to a Process, fwiw. https://github.com/pantsbuild/pants/issues/17116
f
i was just getting there! πŸ˜„
Copy code
12:00:04.32 [ERROR] panic at 'called `Result::unwrap()` on an `Err` value: "Field `argv` was not convertible to type alloc::vec::Vec<alloc::string::String>: PyErr { type: <class 'TypeError'>, value: TypeError(\"'BinaryPath' object cannot be converted to 'PyString'\"), traceback: None }"', src/nodes.rs:366
12:00:04.32 [ERROR] Please set RUST_BACKTRACE=1, re-run, and then file a bug at <https://github.com/pantsbuild/pants/issues>.
thanks! β€” works now! ❀️
g
Is that a new error message you added? (Never seen it before)
f
no, that was found in the pants log β€” i was running my own watcher when i ran pants and found the log file it was writing to disk … and when i checked that the error was found in there … a bit curious that it wasn’t shown directly in the console
g
Huh, interesting. Can you add that bit of info to the issue I linked? That sounds actionable at least to make this less confusing πŸ˜„
f
yes, will do!
❀️ 1
done πŸ˜„