I've encountered a head scratcher. I have an exam...
# general
I've encountered a head scratcher. I have an example repo where I am able to debug without issue, in visual studio, using
./pants test --debug-adapter path/to/target:test
and a remote attach configuration in VSCode. Break points are hit, code is mapped properly. In our company repo, I have integrated pants and tried to use exactly the same configuration but I encounter an error. Any insight as to what is missing? This is the console log. After
Launching debug adapter at '', which will wait for a client connection...
I execute the vsCode remote attach configuration and receive a
KeyError: 'console_scripts'
Copy code
> ./pants test --debug-adapter realtime/tests/test_eeg_processor.py

15:25:59.09 [INFO] Initializing scheduler...
15:25:59.37 [INFO] Scheduler initialized.
15:26:02.63 [INFO] Launching debug adapter at '', which will wait for a client connection...
Traceback (most recent call last):
  File "/Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/3784c3f3/venv/lib/python3.8/site-packages/importlib_metadata/__init__.py", line 288, in __getitem__
    return next(iter(self.select(name=name)))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/private/var/folders/_d/zt8y2x055597l63bhdztp82c0000gn/T/pants-sandbox-pE0mN3/./.cache/pex_root/venvs/6de3f2e95f7514eb53f424a095262c59a1b89864/aa2e58b40d603796246ca3ee285dff9c19064a8b/pex", line 236, in <module>
    runpy.run_module(module_name, run_name="__main__", alter_sys=True)
  File "/Users/russellzarse/.pyenv/versions/3.8.13/lib/python3.8/runpy.py", line 207, in run_module
    return _run_module_code(code, init_globals, run_name, mod_spec)
  File "/Users/russellzarse/.pyenv/versions/3.8.13/lib/python3.8/runpy.py", line 97, in _run_module_code
    _run_code(code, mod_globals, init_globals,
  File "/Users/russellzarse/.pyenv/versions/3.8.13/lib/python3.8/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/3784c3f3/venv/lib/python3.8/site-packages/debugpy/__main__.py", line 45, in <module>
  File "/Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/3784c3f3/venv/lib/python3.8/site-packages/debugpy/server/cli.py", line 444, in main
  File "/Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/3784c3f3/venv/lib/python3.8/site-packages/debugpy/server/cli.py", line 344, in run_code
    eval(code, {})
  File "<string>", line 1, in <module>
  File "/Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/3784c3f3/venv/lib/python3.8/site-packages/importlib_metadata/__init__.py", line 290, in __getitem__
    raise KeyError(name)
KeyError: 'console_scripts'
I have to run an errand so I'll be out for about an hour. Thanks in advance for your help!
What version is this? I recently fixed a handful of debug adapter issues
I'm using
and tried
as well but the problem persists.
It would be in rc1 when released
Can you try
with the latest commit to the 2.15.x branch? https://www.pantsbuild.org/docs/manual-installation#running-pants-from-unreleased-builds
Hot sauce! I tried
and the breakpoints do their thing. I will try
sha and report back. Thanks for fixing it before I found it 😉
☝🏽 Success! Here is the log. Do I have something incorrectly configured re: __PEX_EXTRA_SYS_PATH__?
Copy code
> PANTS_SHA=ecfc54bf1d834f8b74e6c7d5168b1ed451d22276 ./pants test --debug-adapter realtime/tests/test_eeg_processor.py
11:41:08.80 [INFO] Launching debug adapter at '', which will wait for a client connection...
Ignoring the following environment variables in Pex venv mode:
re: __PEX_EXTRA_SYS_PATH__?=.:realtime/neuroedge

============================================================================================= test session starts =============================================================================================
platform darwin -- Python 3.8.13, pytest-7.0.1, pluggy-1.0.0 -- /Users/russellzarse/.cache/pants/named_caches/pex_root/venvs/s/583a7cc0/venv/bin/python3.8
cachedir: .pytest_cache
rootdir: /private/var/folders/_d/zt8y2x055597l63bhdztp82c0000gn/T/pants-sandbox-6S0AA6/realtime, configfile: pytest.ini
plugins: xdist-2.5.0, forked-1.4.0, cov-3.0.0
collected 2 items                                                                                                                                                                                             

realtime/tests/test_eeg_processor.py::test_eeg_interp_stream PASSED                                                                                                                                     [ 50%]
realtime/tests/test_eeg_processor.py::test_eeg_processor PASSED                                                                                                                                         [100%]

============================================================================================== 2 passed in 9.87s ==============================================================================================
No, that's on us. Feel free to open an issue
👍🏽 1