https://pantsbuild.org/ logo
#general
Title
# general
l

loud-laptop-17949

01/19/2023, 6:08 PM
Ok, so I think I have experienced a pants bug, but am having trouble reproducing and narrowing down exactly what's happening. Very occasionally, when running
./pants check
, I will get a failure on a file that shouldn't fail. This seems to always happen on files that are part of more than one resolve and the failure has something to do with missing type stubs. Here are the problems I have had with trying to figure this out: 1. I have tried to reproduce it by running with various forms of caching on and off but cannot find a way to reliably get this to happen or narrow the problem down. 2. the file I get an error on complains about missing type stubs for a library it does not depend on, even transitively Has anyone else seen this? Any suggestions on how to dig into this?
b

bitter-ability-32190

01/19/2023, 6:09 PM
Hmm might be related to the mypy cache
l

loud-laptop-17949

01/19/2023, 6:10 PM
Is that something others have seen?
b

bitter-ability-32190

01/19/2023, 6:11 PM
I think I've seen it in the Pants repo, but not in my work repo 🤔
c

curved-television-6568

01/19/2023, 7:50 PM
I’ve seen mypy fail on
pkg_resources
both in pants repo and work repo occasionally, without being able to find a good repro for it. I’ve also had some major mypy issues (like internal errors thrown by mypy) solved by wiping caches and starting over.
4 Views