https://pantsbuild.org/ logo
#general
Title
# general
c

calm-ambulance-65371

02/02/2023, 7:59 PM
Are there still limitations with using Python versions >3.9 with Pants?
We're on pants 2.13, but are working on upgrading to 2.14.1 if that matters
w

wide-midnight-78598

02/02/2023, 8:01 PM
The limitation was on the Pants runner itself, not your production code. Recently, a new Pants distribution model using embedded interpreters has taken over.
Basically, 1 pants executable on your system, and it will read the
pants.toml
of your current directory (or ask to create one). That way you don't have to provide a Pants-specific interpreter
w

witty-crayon-22786

02/02/2023, 8:09 PM
any Pants plugin code will need to be compatible with Python 3.9, but the rest of your code can use whichever interpreter it would like.
p

proud-dentist-22844

02/02/2023, 8:09 PM
Unless you have in-repo pants-plugins, and then you’ll still need the pants-compatible interpreter to fmt/lint/test those plugins.
lol. @witty-crayon-22786 you beat me to it.
w

witty-crayon-22786

02/02/2023, 8:09 PM
coke 😃
w

wide-midnight-78598

02/02/2023, 8:10 PM
Yeah, wait a sec - that's not in the installation doc?
c

calm-ambulance-65371

02/02/2023, 8:52 PM
Unless you have in-repo pants-plugins, and then you’ll still need the pants-compatible interpreter to fmt/lint/test those plugins.
This is exactly my scenario 😕
further complicated by multiple-resolves because... monorepo
c

cold-vr-15232

02/02/2023, 8:58 PM
Is the new pants binary supposed to work with versions <2.15 too? I tried with 2.14 and it seems ok, but there might be hidden issues
c

calm-ambulance-65371

02/02/2023, 9:12 PM
what's the version string for 2.15?
h

happy-kitchen-89482

02/02/2023, 9:26 PM
current is 2.15.0rc2
I am cutting 2.15.0rc3 as we speak
e

enough-analyst-54434

02/03/2023, 12:02 AM
The new Pants binary works all the way back to Pants v1.late
3 Views