https://pantsbuild.org/ logo
#general
Title
# general
t

tall-country-45957

02/13/2023, 3:18 PM
This message was deleted.
h

happy-kitchen-89482

02/13/2023, 6:04 PM
Hi, sorry you had a bad experience with this. We have large numbers of users on M1 who are not encountering issues, so there may be something going on specifically with your system. I wonder if your shell is running under rosetta, or rosetta is getting involved in some way?
b

boundless-zebra-79556

02/13/2023, 7:33 PM
I've setup pants on M1 to be used among other platforms incl Linux and Intel Mac. Pantsbuild itself might not be the issue per se, but I've run into a lot of issues with science packages that have a hard dependency on scipy and numpy that are not M1 compatible for no reason.
b

busy-vase-39202

02/13/2023, 9:44 PM
@boundless-zebra-79556 That's interesting feedback about science packages. Would you mind opening a ticket with more details so we can track that and hopefully gather additional information from other users?
f

famous-xylophone-36532

02/14/2023, 8:14 AM
Hey guys! Thank you for responding. I am extremely impressed with Pants and have had very positive experiences with it outside of my M1 environment, so I am rooting for you! I don't think Rosetta is to blame. I tried running pants under rosetta to fix the issues, but it didn't solve my problems. It comes down to the fact that generated Pex files seem to be targetting the wrong architecture, or that necessary dependencies aren't being resolved somehow. I can't share the repo as it is internal and proprietary, but I can share the full list of requirements:
Copy code
aiohttp~=3.8.3
aiosignal~=1.2.0
anyio~=3.6.2
async-timeout~=4.0.2
atomicwrites~=1.4.1
attrs~=22.1.0
boltons~=21.0.0
brotli~=1.0.9
certifi~=2022.9.24
cffi~=1.15.1
charset-normalizer~=2.1.1
classes~=0.4.1
click~=8.1.3
colorama~=0.4.5
cryptography~=38.0.1
ecdsa~=0.18.0
environs~=9.5.0
face~=22.0.0
faker-commerce~=1.0.3
faker~=15.3.2
flatten-dict~=0.4.2
frozenlist~=1.3.1
furl~=2.1.3
glom~=22.1.0
idna~=3.4
iniconfig~=1.1.1
marshmallow~=3.18.0
msal~=1.20.0
multidict~=6.0.2
openapi-schema-pydantic~=1.2.4
orderedmultidict~=1.0.1
packaging~=21.3
pluggy~=1.0.0
py~=1.11.0
pyasn1~=0.4.8
pycparser~=2.21
pydantic~=1.10.2
pyjwt[crypto]~=2.6.0
pyparsing~=3.0.9
pytest-mock~=3.10.0
pytest~=7.1.2
python-dateutil~=2.8.2
python-dotenv~=0.21.0
python-jose~=3.3.0
redis~=4.3.5
requests~=2.28.1
returns~=0.19.0
rsa~=4.9
six~=1.16.0
sniffio~=1.3.0
starlette~=0.20.4
tabulate~=0.8.10
tomli~=1.2.3
toolz~=0.12.0
typing-extensions~=4.4.0
urllib3~=1.26.12
yarl~=1.8.1
Trying to run a test on the library with these requirements results in the following message:
Copy code
Failed to resolve requirements from PEX environment @ /Users/peder/.cache/pants/named_caches/pex_root/unzipped_pexes/61b7f8b89bc2656505f1efe0d3e5c7d40323664c.
Needed cp38-cp38-macosx_12_0_arm64 compatible dependencies for:

... (lots of dependencies)
Oh wow, but running from Docker on an x86_64 machine causes the same issue. Very weird! What might be going on here...
Copy code
Failed to resolve requirements from PEX environment @ /root/.cache/pants/named_caches/pex_root/unzipped_pexes/03edf50c1d8897371819584d4094814692505ea8. 
Needed cp39-cp39-manylinux_2_31_x86_64 compatible dependencies for: 
...
Managed to figure this out myself! The issue was how I declared dependencies between the steps. Sorry for being a n00b, and thank you for your time 🙌
👏 2
3 Views