https://pantsbuild.org/ logo
#general
Title
# general
a

aloof-appointment-30987

02/14/2023, 11:14 PM
log using pants 2.16.0.dev6
f

fast-nail-55400

02/15/2023, 7:14 AM
The paths in the log all say `2.16.0.dev5_py38`so you are using dev5 there not dev6. The Go backend was in flux during the 2.16 series, dev5 is unusable for Go.
a

aloof-appointment-30987

02/16/2023, 2:29 PM
Sorry. Looks like I grabbed the wrong log file. What version do you recommend for working with go? Im able to build using 2.16.0dev5 on Mac As well as on GitHub using a Linux image but running under Ubuntu im struggling. I suspect there is something missing, outside of pants, but I can’t seem to identify what that is.
f

fast-nail-55400

02/18/2023, 9:12 AM
2.16.0dev7 was released yesterday and should work well (unless there is a bug here to find)
also a repo with a minimal reproduction with just the relevant third party deps would help as well. then I have something I can run locally on my end to see what is wrong.
4 Views