https://pantsbuild.org/ logo
#general
Title
# general
p

plain-night-51324

02/15/2023, 9:57 PM
running into issues when upgrading flake8 to 6.0.0:
Copy code
ERROR: Could not find a version that satisfies the requirement flake8==6.0.0
ERROR: No matching distribution found for flake8==6.0.0
e

enough-analyst-54434

02/15/2023, 9:58 PM
Requires: Python >=3.8.1
So, I bet ...
p

plain-night-51324

02/15/2023, 9:58 PM
also tried different versions of pants including 2.16
Copy code
[GLOBAL]
backend_packages = [
  "pants.backend.python",
  "pants.backend.python.lint.black",
  "pants.backend.python.lint.flake8",
  "pants.backend.python.lint.isort",
  "pants.backend.build_files.fmt.black",
]
pants_version = "2.15.0rc2"

[python]
enable_resolves = true
interpreter_constraints = ["CPython==3.8.*"]
tailor_pex_binary_targets = false
e

enough-analyst-54434

02/15/2023, 9:58 PM
So read your IC closely
p

plain-night-51324

02/15/2023, 9:59 PM
oh
e

enough-analyst-54434

02/15/2023, 9:59 PM
And realize Pex is keeping you very honest.
p

plain-night-51324

02/15/2023, 9:59 PM
wow
e

enough-analyst-54434

02/15/2023, 9:59 PM
3.8.0 is included in *
p

plain-night-51324

02/15/2023, 9:59 PM
thanks for the tip
how did you know it was >= 3.8.1
e

enough-analyst-54434

02/15/2023, 9:59 PM
I guessed, then read: https://pypi.org/project/flake8/
🙌 1
See the sidebar
Sp adjust your IC and should then work.
Presumably you have no devs using exactly 3.8.0
6 Views