https://pantsbuild.org/ logo
#general
Title
# general
b

breezy-apple-27122

02/27/2023, 9:00 AM
Is pants 2.15 compatible with python 3.11?
For 2.14 it's still reliant on 3.9:
Copy code
No valid Python interpreter found. For `pants_version = "2.14.1"`, Pants requires Python 3.7, 3.8, or 3.9 to run. Please check that a valid interpreter is installed and on your $PATH.
h

high-magician-46188

02/27/2023, 9:12 AM
Hi, I don't think that Pants itself can use Python 3.11 to run yet. Personally, I've moved to use the "Pants launcher" which made me to not care about that subject anymore. I highly recommend it.
b

breezy-apple-27122

02/27/2023, 9:14 AM
The curl command still needs python 3.9 to run. So I had to install it
But I see this is from v2.15
h

high-magician-46188

02/27/2023, 9:16 AM
I see.. I've used
brew
so maybe the
curl
-based version needs a bit more work?
b

breezy-apple-27122

02/27/2023, 9:17 AM
I used it from homebrew and it works. but some developers will need to run it on linux
at least need to wrap the curl on a
/bin/bash -c "$()"
h

high-magician-46188

02/27/2023, 9:46 AM
I think that the devs will appreciate it as a ticket on GitHub, do you mind opening one? (link)
b

breezy-apple-27122

02/27/2023, 1:12 PM
h

happy-kitchen-89482

02/27/2023, 5:47 PM
To clarify - Pants can run your code and tests on 3.11 (or any other Python version). Its own code is compatible with 3.7-3.9, and with the new binary installer it embeds its own 3.9 and you don't have to worry about it.
👍 1
When you say "The curl command still needs python 3.9 to run", do you mean curling the old
./pants
script, or the new
get-pants.sh
script?
b

breezy-apple-27122

02/27/2023, 5:49 PM
Things moved too fast from Wednesday when I started my journey reading the docs to today. I’m ok now with the new binary. But I presume there will be lots of people stuck in the past
h

happy-kitchen-89482

02/27/2023, 5:53 PM
Yeah, we did switch the docs over to 2.15 within that time frame
I can see how that would be confusing
9 Views