When I try to run code with `--debug-adapter` I ge...
# general
When I try to run code with
I get
Copy code
pex.environment.ResolveError: A distribution for scipy could not be resolved for /usr/bin/python3.7.
Found 1 distribution for scipy that do not apply:
1.) The wheel tags for scipy 1.9.3 are cp310-cp310-manylinux_2_17_x86_64, cp310-cp310-manylinux2014_x86_64 which do not match the supported tags of /usr/bin/python3.7:
... 484 more ...
My code uses python3.10 and I have that set in my pants.toml as
Copy code
interpreter_constraints = ["CPython==3.10.*"]
What do I need to do to get the tool to also use a more recent version of python?
Set the debugpy version to 1.6.0 (or later), declare a lockfile, then lock using
generate-lockfiles --resolve=debugpy
The baked-in version of
I suppose doesnt support Py3.10
Setting the version and lockfile didn't help. I did see
in the docs you linked which ended up resolving the problem